[Solved] Anybody using this F4 board and got the USB working?

Limited support for STM32F4 Discovery, Nucleo and custom F4 boards
flodejr
Posts: 29
Joined: Sat Sep 16, 2017 2:46 pm

[Solved] Anybody using this F4 board and got the USB working?

Post by flodejr » Sat Oct 07, 2017 2:30 pm

Hi,

Is anybody using this F4 board?
4048629366.jpg
4048629366.jpg (27.28 KiB) Viewed 430 times
I can get the usb to connect as DFU but it can't work as USB device.

Are there any special requirements to work as a device?
Last edited by flodejr on Mon Oct 09, 2017 8:41 pm, edited 1 time in total.

stevestrong
Posts: 1823
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Anybody using this F4 board and got the USB working?

Post by stevestrong » Sat Oct 07, 2017 4:13 pm

Where did you get it from? Aliexpress/Ebay link?
Any documentation available?

I ma not sure, but it looks like a generic mini board: http://wiki.stm32duino.com/index.php?ti ... 7VET6_Mini

flodejr
Posts: 29
Joined: Sat Sep 16, 2017 2:46 pm

Re: Anybody using this F4 board and got the USB working?

Post by flodejr » Sat Oct 07, 2017 5:28 pm

I got it from ebay.

Think this is the schematics i found on the net.
DIY-More-STM32F407VGT6_smallest.png
DIY-More-STM32F407VGT6_smallest.png (137.59 KiB) Viewed 410 times

stevestrong
Posts: 1823
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Anybody using this F4 board and got the USB working?

Post by stevestrong » Sun Oct 08, 2017 9:02 am

It seems to be a very "basic" F4 version, without any additional chips on it.
Unfortunately the picture is very small size, hardly readable.
Can you post the ebay link?

flodejr
Posts: 29
Joined: Sat Sep 16, 2017 2:46 pm

Re: Anybody using this F4 board and got the USB working?

Post by flodejr » Mon Oct 09, 2017 12:45 am

stevestrong wrote:
Sun Oct 08, 2017 9:02 am
It seems to be a very "basic" F4 version, without any additional chips on it.
Unfortunately the picture is very small size, hardly readable.
Can you post the ebay link?
This is the ebay link
http://www.ebay.com/itm/STM32F407VGT6-A ... 1702413371

and link for the schematics.
http://dubstylee.net/v/wp-content/uploa ... 07VGT6.png

stevestrong
Posts: 1823
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Anybody using this F4 board and got the USB working?

Post by stevestrong » Mon Oct 09, 2017 8:26 am

I don't see any resistor on the USB_DP pin to be connected to Vcc. It should be one there with 1.5kOhm.
flodejr wrote:
Sat Oct 07, 2017 2:30 pm
I can get the usb to connect as DFU but it can't work as USB device.
You mean is does not work as USB serial?
What/how did you try?

User avatar
RogerClark
Posts: 7481
Joined: Mon Apr 27, 2015 10:36 am
Location: Melbourne, Australia
Contact:

Re: Anybody using this F4 board and got the USB working?

Post by RogerClark » Mon Oct 09, 2017 9:07 am

Steve,

I don't think the 1.5k is necessary on the F4. Its supposed to be inside the MCU

flodejr
Posts: 29
Joined: Sat Sep 16, 2017 2:46 pm

Re: Anybody using this F4 board and got the USB working?

Post by flodejr » Mon Oct 09, 2017 9:20 am

stevestrong wrote:
Mon Oct 09, 2017 8:26 am
I don't see any resistor on the USB_DP pin to be connected to Vcc. It should be one there with 1.5kOhm.
flodejr wrote:
Sat Oct 07, 2017 2:30 pm
I can get the usb to connect as DFU but it can't work as USB device.
You mean is does not work as USB serial?
What/how did you try?
I tried by using the cubemx and then specifying CDC Comms for USB_FS but no comm port appear both in linux and windows. I also tried the internal pull up on the DP like, but the comm port doesn't appear. When I put boot1 to 0 and boot0 to X, the DFU appears on both linux and windows.

flodejr
Posts: 29
Joined: Sat Sep 16, 2017 2:46 pm

Re: Anybody using this F4 board and got the USB working?

Post by flodejr » Mon Oct 09, 2017 9:21 am

RogerClark wrote:
Mon Oct 09, 2017 9:07 am
Steve,

I don't think the 1.5k is necessary on the F4. Its supposed to be inside the MCU
I tried the internal pull up on the MCU, but it doesn't bring up the USB port, I think maybe I need to wire a 1.5K resistor externally. WIll there be a problem since there are no 22ohm terminating resisotrs on the DP and DM lines?

stevestrong
Posts: 1823
Joined: Mon Oct 19, 2015 12:06 am
Location: Munich, Germany

Re: Anybody using this F4 board and got the USB working?

Post by stevestrong » Mon Oct 09, 2017 11:39 am

RogerClark wrote:
Mon Oct 09, 2017 9:07 am
I don't think the 1.5k is necessary on the F4. Its supposed to be inside the MCU
Makes sense, otherwise it would not work as DFU either.

I cannot help with Cubemx.
But I think it should work out of the box using the generic F4 board variant of the libmaple core.

Post Reply