Search found 7 matches

by electrobling
Fri May 01, 2020 10:07 pm
Forum: STLink
Topic: Not able to upload code using STLINK ans uart
Replies: 11
Views: 2937

Re: Not able to upload code using STLINK ans uart

Thanks, that clued me to something... I copied over my old sketch folder with "everything but the kitchen sink". It included an alternate core, located in the 'hardware' folder. As soon as I deleted that, I was able to do a SWD upload. Yay! :) Also the upload menu options that appear now make a lot ...
by electrobling
Fri May 01, 2020 3:44 pm
Forum: STLink
Topic: Not able to upload code using STLINK ans uart
Replies: 11
Views: 2937

Re: Not able to upload code using STLINK ans uart

I began to revert to 1.8.10 before I saw your reply. If you think 1.8.12 should work, I will re-install it and try again. Edit - I went ahead and installed 1.8.10 to see what would happen - I get the same behaviour. I have both verbose compilation and upload boxes checked in preferences.. I also tri...
by electrobling
Thu Apr 30, 2020 7:53 pm
Forum: STLink
Topic: Not able to upload code using STLINK ans uart
Replies: 11
Views: 2937

Re: Not able to upload code using STLINK ans uart

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.33.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.33.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\ken\Documents\ArduinoData\packages -hardware C:\Users\ken\D...
by electrobling
Thu Apr 30, 2020 6:29 pm
Forum: STLink
Topic: Not able to upload code using STLINK ans uart
Replies: 11
Views: 2937

Re: Not able to upload code using STLINK ans uart

I installed STM32cubeprogrammer, I can connect to the board and see object code. Arduino IDE still behaves the same.
by electrobling
Thu Apr 30, 2020 5:59 pm
Forum: STLink
Topic: Not able to upload code using STLINK ans uart
Replies: 11
Views: 2937

Re: Not able to upload code using STLINK ans uart

I have exactly the same problem. Also Arduino IDE 1.8.12 with ST-Link V2. STM core is version 1.8.0. I downloaded the driver from the ST site, turned antivirus off and followed directions to install as administrator. Everything looked okay. I have verified ST-Link is connected and working in Windows...
by electrobling
Mon Jan 06, 2020 12:12 am
Forum: General discussion
Topic: Complaint about counterfeit STM32 chips - please read.
Replies: 32
Views: 6999

Re: Complaint about counterfeit STM32 chips - please read.

I have found it quite easy to get refunds or partial refunds from the online cheap board vendors, however it is nearly impossible to get them to change their listing information or product. To them, one complaint per 1000 customers is just a part of doing business and they are just "playing the numb...
by electrobling
Sat Jan 04, 2020 2:10 am
Forum: General discussion
Topic: Blue pill 3D-printable mount
Replies: 6
Views: 1802

Re: Blue pill 3D-printable mount

That would go great with a laser cut acrylic front and back.

Go to advanced search