Search found 7 matches

by RaceAgainstTime
Sat Mar 23, 2024 9:01 am
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

Hi,
Thanks for the help, highly appreciate it.
Will continue using STM32Cube till a solution is found.
by RaceAgainstTime
Sat Mar 23, 2024 7:54 am
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

Hi,
I followed the instructions of enabling "Optimize for Debugging", but the result is still the same.
It doesn't hit the breakpoint.

stm32g491 debug 5.png
stm32g491 debug 5.png (79.86 KiB) Viewed 4376 times
by RaceAgainstTime
Sat Mar 23, 2024 7:34 am
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

fpiSTM wrote: Sat Mar 23, 2024 7:28 am did you build with Optimize for debug selected in the menu ?
No that was disabled.
by RaceAgainstTime
Sat Mar 23, 2024 6:30 am
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

Hi,

I followed the given instructions and pasted the clock init code from generic_clock.c into my sketch.
After entering debugging it doesn't hit the breakpoint.
On pausing the debugger I get the same WWDG location.
stm32g491 debug 3.png
stm32g491 debug 3.png (80.56 KiB) Viewed 2365 times
by RaceAgainstTime
Sat Mar 23, 2024 3:34 am
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

Hi,
If I pause, the call stack shows this
stm32g491 debug 2.png
stm32g491 debug 2.png (66.2 KiB) Viewed 2387 times
Is it something to do with incorrect Watchdog initialisation?
by RaceAgainstTime
Fri Mar 22, 2024 4:56 pm
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Re: Blink not working on STM32G491 Nucleo board

Hi And how does one debug, I don't have any clock initialisation in the sketch, i think that's handled in the "generic_clock.c" file, do I need to open it in a new tab? Also when I run the debugger I can see only the Pause, Restart and Stop button active , the single step buttons are disab...
by RaceAgainstTime
Fri Mar 22, 2024 1:03 pm
Forum: STM boards (Discovery, Eval, Nucleo, ...)
Topic: Blink not working on STM32G491 Nucleo board
Replies: 12
Views: 6867

Blink not working on STM32G491 Nucleo board

Hi, Have been trying to get the blink sketch to work on my STM32G491 Nucleo board (NUCLEO-G491RE), but it refuses to work, although the board programs successfully. Tools Version Arduino IDE : 2.3.2 Core: STM32 MCU Based Boards by STMicroelectronics v2.7.1 output log Sketch uses 15988 bytes (3%) of ...

Go to advanced search