Search found 3 matches

by dwestbury
Mon Jul 06, 2020 3:52 am
Forum: IDE's
Topic: [SOLVED]Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5
Replies: 3
Views: 1371

[SOLVED]Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5

OK.. Fake STM32 chip or not, I've figured out how to get it to program properly with a STLink v2 in the Arduino IDE. In the end, it was a simple matter of following these directions properly. It turns out that the SetupSTM32CubeProgrammer-2.4.0 I downloaded from st.com was actually a Mac 'app', whic...
by dwestbury
Mon Jul 06, 2020 3:04 am
Forum: IDE's
Topic: [SOLVED]Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5
Replies: 3
Views: 1371

Re: Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5

For what it's worth, the MCU chips on my boards don't have any of the same red flags listed by the under cnx-software.com link, but they don't have the ST logo on them at all and perhaps worst of all, a simple swipe of an alcohol dipped cotton swab, almost completely removed the print on the chip. G...
by dwestbury
Sun Jul 05, 2020 10:39 pm
Forum: IDE's
Topic: [SOLVED]Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5
Replies: 3
Views: 1371

[SOLVED]Unable to Program Blue Pill in Arduino IDE v1.8.12 on Mac Catalina 10.15.5

I recently purchased two batches of generic STM32F103C's from different suppliers. I was able to program the first batch of boards using a simple FTDI USB-Serial interface in Arduino IDE v1.8.12 on my Mac running Catalina 10.15.5. However, I haven't been able to get any of the boards from second bat...

Go to advanced search