Search found 19 matches

by mauriziostm32
Mon Apr 20, 2020 7:14 am
Forum: STM32 HID bootloader
Topic: Having a problem with bootloader after uploading code
Replies: 27
Views: 7382

Re: Having a problem with bootloader after uploading code

Hi Guys Thanks for the help and the hints. stas2z nvic_sys_reset() is working... for the second point I was hoping in a function()… like for the soft reset nvic_sys_reset()… the recompiling and coding solution is a little bit too time consuming in relation to my actual knowledge... as always I like ...
by mauriziostm32
Sun Apr 19, 2020 11:05 am
Forum: STM32 HID bootloader
Topic: Having a problem with bootloader after uploading code
Replies: 27
Views: 7382

Re: Having a problem with bootloader after uploading code

Hi Steve It seems there is no driver to uninstall... so when I install the device and re-plug, the PC says that cannot install, I try to let the PC go on internet but it says there is no driver for this device... I think this PC is a little bit messed up I have 2 more question a little bit out of to...
by mauriziostm32
Sun Apr 19, 2020 9:23 am
Forum: STM32 HID bootloader
Topic: Having a problem with bootloader after uploading code
Replies: 27
Views: 7382

Re: Having a problem with bootloader after uploading code

Hi Guys I tried on another PC and as soon as I plugged the cable the device was recognized and the driver was self installed (or just the device was associated with the existing CDC driver) by windows 7... I attach the picture... So it seems that for some reason the other PC doesn't have the driver ...
by mauriziostm32
Sun Apr 19, 2020 9:05 am
Forum: STM32 HID bootloader
Topic: Having a problem with bootloader after uploading code
Replies: 27
Views: 7382

Re: Having a problem with bootloader after uploading code

Hi Guys Thanks to you all... Thanks to Stevestrong for the effort on keeping alive and updated the original Roger's... I'm looking forward for the CDC ;) fpiSTM it seems my standard W7 installation doesn't have the driver??? very strange... I attach the picture Tried on different port... but to be s...
by mauriziostm32
Sun Apr 19, 2020 2:30 am
Forum: STM32 HID bootloader
Topic: Having a problem with bootloader after uploading code
Replies: 27
Views: 7382

I'm having problems too

Hi Guys First of all thanks to Vassilis for this bootloader and to all the other that are helping and pushing on... I like the idea to have a Hid Bootloader... but maybe I didn't entirely understand the concept.. It is clear what Stevestrong punctuated: after you upload the first sketch the Bootload...
by mauriziostm32
Fri Apr 03, 2020 1:44 pm
Forum: General discussion
Topic: Using the CORE with OR without BOOTLOADER: problems
Replies: 4
Views: 1211

Re: Using the CORE with OR without BOOTLOADER: problems

Hi Steve ;) Ok it seems to work. Thanks But I have 2 different results depending if I upload the code on a bluepill or on my circuit based on an stm32f103c8t6 this sequence enable the pins to work … and further uploads are successful on the bluepill... disableDebugPorts(); delay(100); enableDebugPor...
by mauriziostm32
Fri Apr 03, 2020 10:00 am
Forum: General discussion
Topic: Using the CORE with OR without BOOTLOADER: problems
Replies: 4
Views: 1211

Re: Using the CORE with OR without BOOTLOADER: problems

Short answer: include early in your setup enableDebugPorts(); Long info: check this: https://github.com/rogerclarkmelbourne/Arduino_STM32/commit/a8d1c1d1b614a5ed6924df3facc72a5f9980e34d#commitcomment-38078911 Hi Steve Thanks for the fast answer, I think I understood, but to be sure I summarize: Nor...
by mauriziostm32
Fri Apr 03, 2020 6:23 am
Forum: General discussion
Topic: Using the CORE with OR without BOOTLOADER: problems
Replies: 4
Views: 1211

Using the CORE with OR without BOOTLOADER: problems

Hi Guys Maybe there are some problems using Roger's CORE if not in conjunction with the USB bootloader? (https://github.com/rogerclarkmelbourne/Arduino_STM32) I use Arduino IDE 1.8.5 Here is my problem: simple code in the SETUP pinmode (PB4, INPUT_PULLDOWN) digital.Read(PB4) It works if I upload the...
by mauriziostm32
Sat Mar 21, 2020 3:20 pm
Forum: Announcements
Topic: Welcome back stm32duino.com
Replies: 29
Views: 12258

Re: Welcome back stm32duino.com

Thanks

Good to be back...

Go to advanced search