No STM32 Target Found

If you made your own board, post here, unless you built a Maple or Maple mini clone etc
Post Reply
Ooozair
Posts: 5
Joined: Fri Jan 15, 2021 5:24 pm

No STM32 Target Found

Post by Ooozair »

Hi guys, I recently made a post about using a STM32G071CB: viewtopic.php?f=14&t=912

The problem I was having was that I couldn't get an ST-Link to read the chip on a breadboard. I'm having the same problem with a G070KB now, and while I was able to solve the problem in my last post, I'm again at a dead end. I'm really sorry if I'm missing something obvious or asking what might be obvious questions here- I'm new to embedded systems. I've checked the spec sheets and getting started guide, nothing seems to indicate that I've set anything up incorrectly.

Here's my schematic: https://imgur.com/a/y27Dr3f

I'm using a LQFP32-to-DIP socket to interface with the chip, no soldering, so I know it's not a bad joint somewhere. I've tried with 3 different chips.

Things I've tried:
Tried pulling and shorting BOOT0 High and Low upon startup, no luck.
Tried manually resetting via the RST pin pulling Low, on startup and after startup, no luck.
With and without the 8MHz crystal
Using 3.3V from the ST-Link, and providing my own 3.3V with a LDO supplied with 5V.

Regardless of what I try, I get the following error in STM32CubeProgrammer:
12:19:03 : ST-LINK SN : 3837130012144D43574D4E00
12:19:03 : ST-LINK FW : V2J37S7
12:19:03 : Board : --
12:19:03 : Voltage : 3.16V
12:19:03 : Error: No STM32 target found!


I've got the appropriate capacitors on board, I've checked all the connections with a multimeter, the real-life breadboard setup is exactly as shown in the schematic.

I know my ST-Link works because it works for all my bluepills and my custom G071CB board. Sadly, the G070KB is what we've decided to use for our next stage prototype due to cost optimizations.

I see that several of you guys have used this chip successfully in your own custom boards- could anyone share a schematic?
mrburnette
Posts: 479
Joined: Thu Dec 19, 2019 1:23 am
Answers: 2

Re: No STM32 Target Found

Post by mrburnette »

I am assuming you do not have an o'scope or logic analyzer to check your new prototype.

Do you have access to a battery powered transistor radio with an AM function? If so, move your board far away from your workbench, WiFi router, Laser printers, etc.
- Tune the AM radio to a no-station location on the tuning dial, (lower frequencies to start)
- Power-on the prototype board,
- If the clock is working, you will get lots of digital hash. Retune to find a solid, stable signal.

Assuming the clock is a-clocking, put the prototype back on the ST-Link, adjust the radio for a good clock hash sound, try to flash.

I recommend doing the above with a working board to become familiar with what happens (sounds) at different times.
fredbox
Posts: 125
Joined: Thu Dec 19, 2019 3:05 am
Answers: 2

Re: No STM32 Target Found

Post by fredbox »

A quick DDG search finds http://ims-kharkov.narod.ru/stm32pcb.htm which has several links to schematics. The page is in Russian, but appears to contain one schematic that matches your processor.
Post Reply

Return to “Custom design boards”