Arduino Pro IDE and STM32

Development environment specific, Arduino, Eclipse, VS2013, Em::Blocks etc
Post Reply
User avatar
mpetrasinovic
Posts: 7
Joined: Fri Apr 17, 2020 1:25 pm
Location: Belgrade, Serbia
Contact:

Arduino Pro IDE and STM32

Post by mpetrasinovic »

Is someone able to use STM32 boards with Arduino Pro IDE?

User avatar
fpiSTM
Posts: 664
Joined: Wed Dec 11, 2019 7:11 pm
Answers: 25
Location: Le Mans
Contact:

Re: Arduino Pro IDE and STM32

Post by fpiSTM »

I never tried yet, I have to test it in the coming weeks

User avatar
mpetrasinovic
Posts: 7
Joined: Fri Apr 17, 2020 1:25 pm
Location: Belgrade, Serbia
Contact:

Re: Arduino Pro IDE and STM32

Post by mpetrasinovic »

I have managed to compile the sketch for STM32 using the 0.1.1 version of Arduino Pro IDE, the next step is definitely debugger!

User avatar
fpiSTM
Posts: 664
Joined: Wed Dec 11, 2019 7:11 pm
Answers: 25
Location: Le Mans
Contact:

Re: Arduino Pro IDE and STM32

Post by fpiSTM »

mpetrasinovic wrote:
Tue Sep 01, 2020 8:54 am
I have managed to compile the sketch for STM32 using the 0.1.1 version of Arduino Pro IDE, the next step is definitely debugger!
Fine. Yes the debugger would be definitely the best feature.

User avatar
Juraj
Posts: 26
Joined: Fri Jan 03, 2020 7:47 pm
Answers: 1
Location: Slovakia
Contact:

Re: Arduino Pro IDE and STM32

Post by Juraj »

I can step debug the Blue Pill in Eclipse Sloeber with ST-Link.
I have in boards.txt in my_boards custom definitions (https://github.com/jandrassy/my_boards) this lines added
BluePill128kswd.build.flags.optimize=-g -Og
BluePill128kswd.compiler.c.extra_flags=-DDEBUG
BluePill128kswd.compiler.cpp.extra_flags=-DDEBUG
BluePill128kswd.compiler.elf2hex.extra_flags=--debugging

other lines in this boards.txt are only to have less options to select when I select the board

User avatar
mpetrasinovic
Posts: 7
Joined: Fri Apr 17, 2020 1:25 pm
Location: Belgrade, Serbia
Contact:

Re: Arduino Pro IDE and STM32

Post by mpetrasinovic »

Juraj wrote:
Tue Sep 01, 2020 4:15 pm
I can step debug the Blue Pill in Eclipse Sloeber with ST-Link.
I have in boards.txt in my_boards custom definitions (https://github.com/jandrassy/my_boards) this lines added
BluePill128kswd.build.flags.optimize=-g -Og
BluePill128kswd.compiler.c.extra_flags=-DDEBUG
BluePill128kswd.compiler.cpp.extra_flags=-DDEBUG
BluePill128kswd.compiler.elf2hex.extra_flags=--debugging

other lines in this boards.txt are only to have less options to select when I select the board
Have you tried Arduino Pro IDE?

Post Reply

Return to “IDE's”