Porblems with HID Bootloader

Bootloader for STM32F103 and STM32F4xx micro-controllers
No special driver is required. Support for Windows, Linux and Mac Operating System
Post Reply
jenspogo
Posts: 29
Joined: Mon Feb 24, 2020 10:42 am

Porblems with HID Bootloader

Post by jenspogo »

Hey Guys,
I tried to use the HID Bootloader. And i Got this error message:

Code: Select all

+-----------------------------------------------------------------------+
|         HID-Flash v2.2.1 - STM32 HID Bootloader Flash Tool            |
|     (c)      2018 - Bruno Freitas       http://www.brunofreitas.com   |
|     (c) 2018-2019 - Vassilis Serasidis  https://www.serasidis.gr      |
|   Customized for STM32duino ecosystem   https://www.stm32duino.com    |
+-----------------------------------------------------------------------+

> Trying to open the [COM13]...
> Unable to open the [COM13]
> Searching for [1209:BEBA] device...
#
> [1209:BEBA] device is found !
> Sending <reset pages> command...
> Flashing firmware...
. 1024 Bytes
Beim Hochladen des Sketches ist ein Fehler aufgetreten 
the last line says "Error while uploading code" (in german)

Does someone know what went wrong here? Beacause it seems, that the Board was found...
Greetings, Jens

stevestrong
Posts: 387
Joined: Fri Dec 27, 2019 4:53 pm
Answers: 7
Location: Munich, Germany
Contact:

Re: Porblems with HID Bootloader

Post by stevestrong »

Which board, which MCU do you use?
Is the upload done manually or within Arduino IDE?
If Arduino, which core do you use?

jenspogo
Posts: 29
Joined: Mon Feb 24, 2020 10:42 am

Re: Porblems with HID Bootloader

Post by jenspogo »

Hey,
sorry - I should have known that this have been not enough informations.
I'm using a Bluepill Board with STM32F103C8T6 Processor on it.
The bootloader was programmed with stm32Cubeprogrammer.
Upload is done in the Arduino IDE.
And I'm using the official core from https://github.com/stm32duino/BoardMana ... index.json

jenspogo
Posts: 29
Joined: Mon Feb 24, 2020 10:42 am

Re: Porblems with HID Bootloader

Post by jenspogo »

Hey guys,

I used another PC to try it again and it works - seems to have something to do with my notbook.

Greets, Jens

Post Reply

Return to “STM32 HID bootloader”