Mac OS X 10.15.2 catalina, cube MX and sw4stm32

Post here first, or if you can't find a relevant section!
Post Reply
sheepdoll
Posts: 9
Joined: Fri Dec 20, 2019 6:47 pm

Mac OS X 10.15.2 catalina, cube MX and sw4stm32

Post by sheepdoll »

So my tusty 2012 mac mini bit the dust. I got new 2018 version. They completly re -did it as a media device. even making it black in color,

As It was a new machine I decided to go with the latest system. The internal drive is soldered in, But I have everything backed up anyway to an external disk. (I am keeping my laptop on high sierra.) It is amazing how much of one's user preferences, custom fonts (sountfonts too) are hidden. Eveen the shell changed from bash to zshell.

Catalina of course does away with 32 bit support. As the ST software is java I thought to try it anyway. CubeMX however will not install as it attempts to access the read only partition. Am currently attempting instlation of AC6 sw4stm32 eclipse which is installed from the terminal. That seens to work. The instuctions for this are to temporally turn off gatekeeper

I tried this method with cubeMX and it worked Here are the instructions:

Code: Select all

sudo spctl --master-disable
I then decided to run the installer from the command line this involved cd into the app directory. Making it executable then running it from the shell as root

Code: Select all

cd downloads/en.stm32cubemx_v5-5-0
cd SetupSTM32CubeMX-5.5.0.app/contents/MacOs
chmod 755 SetupSTM32CubeMX-5_5_0_macos
The first attempt said the JRE needed upgrading the osx dialog prompts took me to the oracle download page.
once java was updated

Code: Select all

sudo ./SetupSTM32CubeMX-5_5_0_macos
Ran the installer and put the app into the applications directory

Both stmCubeMx abd AC6 sw4stm32 now will run and launch from the applications folder

Be sure to turn gatekeeper back on otherwise unwanted apps can self insall

Code: Select all

sudo spctl --master-enable
Next up is to renstall the Arduno IDE ...



-julie

Post Reply

Return to “General discussion”