How to use Maple Mini as USB Midi Device

Maple Mini, Maple Rev3, Maple Rev 5 and Maple Ret 6, iTead Maple etc
Post Reply
Posts: 1
Joined: Mon Apr 25, 2022 8:07 am

How to use Maple Mini as USB Midi Device

Post by Flub »

Hey there,
I am trying to somehow make the maple mini a usb midi device that receives midi clock from any midi usb host and outputs din sync signals.

I want to use the Arduino IDE to upload the code via the usb cable.
To make that possible i use and usb-ftdi adapter and the STM32CubeProgrammer Software to flash a bootloader which allows uploading sketches via usb to the board.

This seems to work successfully when i connect the boot1 pin to GND and then hold the buf=32 button while clicking the reset button. Then I can connect with the STM32CubeProgrammer Software and upload the bootloader bin file.

I tried different bootloaders starting with
which i downloaded here ( i did this some years ago on a windows machine and it worked back then) ... y_binaries

But after flashing those bootloaders to the starting address 0x08000000, removing the GND connection of Boot1 and reattaching the usb cable of the maple mini, in both cases it just blinks very quickly and then does nothing. I also cannot see it as a device under ports in the arduino ide then.

Then i searched in the web and found this
I followed the steps to flash the HID Bootloader and could successfully upload sketches to the board then.

Then i tried to find a solution on how to make it a usb midi device which is receiving midi clocks and outputs a din sync signal, but all i found was related to the Arduino_STM32 library which i cannot use because the board is not detected if I flash the corresponding bootloader.

I am confused if I can still use this
or if I should the "official" STM32 Board option from the arduino ide's board manager

Can someone explain to me how it might be possible to make the maple_mini board a usb midi device?
I found this but it didnt really help because i cannot even compile this code with the IDE and i think it is based on the Arduino_STM32 Lib which i cannot use (because the bootloader is not working for me)

My Specs:
Mac OS Catalina 10.15.7
Maple Mini with letters BTEI4-097 on it and the MCU STM32F106CBT6 connected via usb

Thank you for any help on this,
Post Reply

Return to “Maple & Maple mini etc”